You are not logged in.

#1 01-28-2012 03:20:15

Nouveau membre
Registered: 01-28-2012
Posts: 3

[Solved]Audio Error on OpenSuse x64


I have exhausted all of my ideas, so now I am here is the forum.

Sadly, the audio does not work for me on my OpenSuse 12.1 86_x64 configuration.

I receive the error: Error in SDLAudioCallback : Wanted len( 4096 )<>MixedMusic.SoundPacketSize( 3840 )
This occurs no matter what I try.

I have tried reinstalling all the dependencies from different repositories.
I have built the binaries from source.
I have researched SDL audio problems with no avail.

ffDiaporama audio works on the i586 build of OpenSuse on my very old laptop (screen to small to work with).

the Slide presentation renders with the sound.

All other audio software works on my machine.

Any help or suggestions would be helpful.

Thanks in advance for your help.



#2 01-28-2012 06:06:06

Registered: 09-17-2011
Posts: 1,080

Re: [Solved]Audio Error on OpenSuse x64

Hi Cluehawk

In the past I've experienced the same problem when SDL was using other thing than pulseaudio on alsa.
I'm not a Suse expert but
- Ensure pulseaudio and alsa-plugin-pulse were correctly installed and configured in your system.
- Try to reinstall libsdl after having completly remove it (also remove configuration files)

Processeur i5 - 8 Go RAM - Manjaro Linux KDE (64 bits) / Windows 7 (64 bits)


#3 01-28-2012 07:20:48

Nouveau membre
Registered: 01-28-2012
Posts: 3

Re: [Solved]Audio Error on OpenSuse x64


Your advice was well given.

The solution was:

  1. Enable Pulseaudio - duh!
      - It was disabled because the configuration was corrupt
      - # setup-pulseaudio --enable

  2. Fix the Pulseaudio configuration
      - pulseaudio doesn't work well with two sound cards (defaults to HDMI audio)
      - change output in /etc/pulse/ to select correct device

Thanks for pointing me in the right direction.


Board footer