You are not logged in.

#1 02-10-2015 05:40:58

Registered: 02-10-2015
Posts: 12

v2.1 - "application fails to initialize properly"


I would welcome any suggestions or advice with my problem . . .

• System:
Windows VISTA (SP-1) Home Premium Edition / 2 QUAD CPU / 32-bit/

• Version:

• Problem:
After installation, the following message (error box) appears when launching program — "The application failed to initialize properly (0xc0000142). Click OK to terminate the application."


(a) Here's what I've done so far in attempting to resolve the problem, without success:

(1) installed and UN-installed the programme several times using the "default" installation directory (C:\Program Files\ffDiaporama)
(2) tried installation with my security software (COMODO) both on and off
(3) Changed compatibility mode to Win-XP in File Properties
(4) Tried launching from both the shortcuts and also the program.exe in Program Folder
(5) checked the Task Manager when error box appears — this shows the program *is* running and using between 12.5 to 13.5 MB Ram (at different times)

(c) Then some r-eally weird stuff happened:

(1) I downloaded a fresh setup.exe
(2) At installation, the following message box appeared — "A previous version of ffDiaporama is already installed. Click OK to uninstall it."
(3) I click OK, installation completes and software launches ... but ... although the program *is* running, it's in low 8-bit 256 colours (yuk) ... and ... there is no installation folder and so, when I close the program, there's nothing left on my system — which is to say I cannot launch it again.

I managed to duplicate this phenomena and, while the program was running, used its "Check Configuration" function which showed all the components on my system are "green" except for two things which are "yellow — (i) Windows media Video 9; and (ii) ASF/Windows Media Video Format.

Thank you for any advice or suggestion.


#2 02-19-2015 14:46:44

Registered: 09-19-2011
Posts: 463

Re: v2.1 - "application fails to initialize properly"


"yellow — (i) Windows media Video 9; and (ii) ASF/Windows Media Video Format.

This is normal.

go to add remove programs Uninstall all ffDiaorama app.
go to C:\Users\(your user name)\AppData\Roaming, and delete ffdiaporama folder.
Reinstall ffDiaporama


#3 02-21-2015 04:44:25

Registered: 02-10-2015
Posts: 12

Re: v2.1 - "application fails to initialize properly"

Greetings Sestay — thank you very much for responding.

I followed your advice and made a clean un-install of the programme (including all its registry entries) and then re-installed.

The problem has been resolved ... sort of. The issue is not with ffDiaporama — it's with COMODO, my security software.

I won't take up space detailing the convoluted process I went through to discover this, but, in brief ... I *can* run the software using COMODO's "virtual-desktop-mode" which, for now, is okay.

I don't know why there's a conflict with COMODO, and yet I'm pleased that I persisted in finding a solution (of sorts) because I'm very impressed with ffDiaporama and will certainly recommend it to others.




Board footer