You are not logged in.

#1 03-21-2012 19:54:00

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello,

in your forum I read the procedure to get ffDiaporama 1.2.1 (a great
program) run under opensuse 12.1 with the actual ffmpeg from the packman
repository.

So I compile it as it wrote.

The program runs and I can edit a project. But when I was generatin an
HD-File i mkv or a lossless file ffDiaporama crashes.

I can't see where is an error in the process. Pherhaps you could help
me. I send you the two files (debug and terminal output) from the debug
run.

The program crashes only when music should be mux into the file. Without music muxing the file would be created fine but in silence.

Thanks

Offline

#2 03-26-2012 20:08:48

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello again,

i've worked at the problem a little bit. On my 64-bit updated Opensuse System and with the 1.3dev Version I got with large projects the same error on all rendering situations. -> segfault.

With short project (only a few pictures like loremipsum with added sound) the program works fine and perfect. Sometimes I got also a result on a fresh started system.

Without sound, all ist perfect.

So I hope I could helo a little bit more

Offline

#3 03-27-2012 05:44:48

domledom
Administrateur
Registered: 09-17-2011
Posts: 1,080

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello

Sorry to not have answered you faster.
I have little time at the moment and moreover, I am working on a new complex feature which makes my code not compilable.
I hope I can publish a new 1.3 build this weekend.
From there I can take care a little more on your problem
I do not think that it will take me a lot of time, thus I advice you to watch the forum and the news this weekend.


Processeur i5 - 8 Go RAM - Manjaro Linux KDE (64 bits) / Windows 7 (64 bits)

Offline

#4 04-01-2012 21:54:42

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello again,

I've tried your new development version too like schukra. After compiling it on an updated linux opensuse 12.1 64-bit on an AMD-System it works great for editing and for rendering projects smaller than 25 fotos with sound. If I try to render more than apr. 25 or 30 pictures, then the program crashes with an segmentation fault during the soundprocessing in the beginning. Without sound - no problem

My system is updated with the newest packages of the packman rep's and actual packages from opensuse updating.

Perhaps you could now hav a little time for the problem, to generate a better version of this great program. The version 1.1 works without any problems out of the package.

Thanks a lot

norbert

Offline

#5 04-02-2012 18:47:51

domledom
Administrateur
Registered: 09-17-2011
Posts: 1,080

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

I think I have solved this issue.
Could you please try new devel version I publish today.


Processeur i5 - 8 Go RAM - Manjaro Linux KDE (64 bits) / Windows 7 (64 bits)

Offline

#6 04-03-2012 07:04:20

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Thanks for the quick feedback.

This morning I could test the new version a little bit.
Started from the desktop (LXDE) the program crashed unfortunately again at the sound processing. Whether lossles nor mkv or ... rendering start. Started from a console it stops with a segfault error. To watch a debug file then I started on the console in loglevel = 1
The program runs ... and render the film! Whow - a funny bug. So I verified it. From the console the program is reproducly in loglevel = 1 stabile. Without loglevel=1 it crashes.

If necessary, I can send you a debug file late in the afternoon.

Offline

#7 04-03-2012 07:11:09

domledom
Administrateur
Registered: 09-17-2011
Posts: 1,080

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello
It's probably due to a timer event : In loglevel=1 it send more information and so consume more time to do it.
Yes, please, send me a log file.


Processeur i5 - 8 Go RAM - Manjaro Linux KDE (64 bits) / Windows 7 (64 bits)

Offline

#8 04-03-2012 21:45:54

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello Dominique,

sorry, its a little bit late but here you get the logfiles.

In loglevel 2 the programm crashed with segfault error. Therefore you
get the files "*loglevel 2.txt"

In loglevel 1 it runs and rendered. Therefore I send you "*-loglevel
1.txt".

Both with debug code and cmdline output.

I hope it will help you to find and kill the bug.

Greetings
Norbert

Offline

#9 04-09-2012 20:58:34

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello,

here I am again. I hope Eastern have had some nice eggs for you :-))

So I loaded the last version of diaporama today from your site. And ..... the problem is still the same. The logfiles for runlevel 1 (when it works without problems) and for normal level (when it crashes at sound rendering) comes with E-Mail.

For explaning the problem here some facts.

I load a project file with 201 Fotos and 2 HD-Videos. Among the timeline , where the first song stops the next song should start with the next slide. There are 4 songs in the project all as mp3.

In loglevel=1 (*loglevel-1.txt) the project start and runs through the hole process without any problems. After 15 through 20% it stops a little bit but then it  goes through. The program can use 2GB from my 6 GB memory.

If there is marked no loglevel or loglevel >=2 then I have trouble. The process stops at 6% or a little bit more with a segfault error. At any rendering process ( to mpeg or lossless or ...)

But ... if there are marked only 20 through 30 dia's all is OK. More than 35 Dias it makes trouble.

It looks like a timer problem with the free memory for the process. But my knowledge of the programming API's a max. worst to help you. So I could only describe the process.

So on

Norbert

Offline

#10 04-09-2012 22:15:03

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello again,

I've tested the new version on my Laptop alternativly.

Ther it runs!!!  Only sometimes with problems.

On my Desktop I still have problems (System AMD Phenom 9550 Quad-Core 2,200 GHz 6GB Memory)

On my Laptop the proces runs (System Intel i3 CPU M380 2,530 GHz 4GB Memory)

On both Systems run the same OS (Opensuse 12.1 LXDE updated packages)

For testing the program I've copied the compiled version of ffDiaporama from my Desktop to the Laptop.

Addig Fotos n sound .... it runs.

But not on the Desktop.

Stay tuned, I will test it more...

Norbert

Offline

#11 04-30-2012 22:08:20

meinereiner
Membre
From: Fulda
Registered: 03-21-2012
Posts: 71

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello,

are there anything news about my bug? It seems I am the only one who has this suspicious bug. With the last version the program works better on editing a film, but when I try to render the film it crashes on resampling the sound.

I don't know how the workflow of the program should be, therfor I didn't have the time to read the complete code. But if I could help to kill the bug, let me know.

For now I take the workaround to run the program with loglevel=1. Then it runs.

Greetings

Offline

#12 05-01-2012 06:21:25

domledom
Administrateur
Registered: 09-17-2011
Posts: 1,080

Re: Error on generation a mkv file under opensuse 12.1 with version 1.2.1

Hello

I confirm you that you are the only one to have to speak about this bug.
For the moment, I am working on the transfer towards libav/avconv (abandonment of ffmpeg) and unfortunately it takes me more time than I had hoped for it.

These works shall maybe allow to correct your problem.


Processeur i5 - 8 Go RAM - Manjaro Linux KDE (64 bits) / Windows 7 (64 bits)

Offline

Board footer